BETA

8th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [08/09/18 01:06 PM] with 'Major Outage'

Issue has been resolved at [08/09/18 01:07 PM]