BETA

8th September 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [08/09/18 12:09 PM] with 'Major Outage'

Issue has been resolved at [08/09/18 12:10 PM]