BETA

18th April 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [18/04/17 12:55 PM] with 'Major Outage'

Issue has been resolved at [18/04/17 12:56 PM]