BETA

8th September 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [08/09/18 06:25 AM] with 'Partial Outage'

Issue has been resolved at [08/09/18 06:28 AM]