BETA

18th June 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [18/06/19 05:53 AM] with 'Partial Outage'

Issue has been resolved at [18/06/19 05:55 AM]