BETA

8th September 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [08/09/18 02:53 AM] with 'Major Outage'

Issue has been resolved at [08/09/18 02:56 AM]