BETA

7th September 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [07/09/18 01:24 PM] with 'Major Outage'

Issue has been resolved at [07/09/18 01:30 PM]