BETA

6th September 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [06/09/18 05:08 AM] with 'Partial Outage'

Issue has been resolved at [06/09/18 05:10 AM]