BETA

5th September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [05/09/18 03:14 PM] with 'Major Outage'

Issue has been resolved at [05/09/18 03:20 PM]