BETA

5th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [05/09/18 02:36 PM] with 'Partial Outage'

Issue has been resolved at [05/09/18 02:39 PM]