BETA

5th September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [05/09/18 11:52 AM] with 'Major Outage'

Issue has been resolved at [05/09/18 11:53 AM]