BETA

5th September 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [05/09/18 09:25 AM] with 'Partial Outage'

Issue has been resolved at [05/09/18 09:27 AM]