BETA

4th September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [04/09/18 11:20 AM] with 'Partial Outage'

Issue has been resolved at [04/09/18 11:36 AM]