BETA

4th September 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [04/09/18 05:38 AM] with 'Partial Outage'

Issue has been resolved at [04/09/18 05:44 AM]