BETA

4th September 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [04/09/18 01:35 AM] with 'Partial Outage'

Issue has been resolved at [04/09/18 01:55 AM]