BETA

3rd September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [03/09/18 07:34 PM] with 'Partial Outage'

Issue has been resolved at [03/09/18 09:34 PM]