BETA

3rd September 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [03/09/18 04:19 PM] with 'Partial Outage'

Issue has been resolved at [03/09/18 04:20 PM]