BETA

17th April 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [17/04/17 04:30 PM] with 'Partial Outage'

Issue has been resolved at [17/04/17 04:36 PM]