BETA

17th April 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [17/04/17 04:23 PM] with 'Partial Outage'

Issue has been resolved at [17/04/17 04:24 PM]