BETA

3rd September 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [03/09/18 03:18 PM] with 'Partial Outage'

Issue has been resolved at [03/09/18 03:21 PM]