BETA

3rd September 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [03/09/18 01:41 PM] with 'Major Outage'

Issue has been resolved at [03/09/18 01:44 PM]