BETA

1st September 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [01/09/18 01:58 PM] with 'Major Outage'

Issue has been resolved at [01/09/18 02:00 PM]