BETA

1st September 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [01/09/18 11:46 AM] with 'Partial Outage'

Issue has been resolved at [01/09/18 11:47 AM]