BETA

1st September 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [01/09/18 07:55 AM] with 'Major Outage'

Issue has been resolved at [01/09/18 08:08 AM]