BETA

31st August 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [31/08/18 07:47 PM] with 'Major Outage'

Issue has been resolved at [31/08/18 07:48 PM]