BETA

31st August 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [31/08/18 12:56 PM] with 'Partial Outage'

Issue has been resolved at [31/08/18 12:58 PM]