BETA

31st August 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [31/08/18 11:45 AM] with 'Partial Outage'

Issue has been resolved at [31/08/18 11:56 AM]