BETA

17th April 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [17/04/17 01:39 PM] with 'Major Outage'

Issue has been resolved at [17/04/17 01:42 PM]