BETA

30th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [30/08/18 09:11 PM] with 'Partial Outage'

Issue has been resolved at [30/08/18 09:12 PM]