BETA

30th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [30/08/18 07:16 PM] with 'Partial Outage'

Issue has been resolved at [30/08/18 09:19 PM]