BETA

30th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [30/08/18 04:33 PM] with 'Partial Outage'

Issue has been resolved at [30/08/18 06:46 PM]