BETA

30th August 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [30/08/18 10:13 AM] with 'Major Outage'

Issue has been resolved at [30/08/18 10:21 AM]