BETA

29th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [29/08/18 06:45 AM] with 'Major Outage'

Issue has been resolved at [29/08/18 06:47 AM]