BETA

29th August 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [29/08/18 02:49 AM] with 'Partial Outage'

Issue has been resolved at [29/08/18 02:51 AM]