BETA

28th August 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [28/08/18 07:57 PM] with 'Major Outage'

Issue has been resolved at [28/08/18 07:58 PM]