BETA Singapore cluster       Mumbai cluster

14th June 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [14/06/19 02:46 PM] with 'Partial Outage'

Issue has been resolved at [14/06/19 02:49 PM]