BETA

14th June 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [14/06/19 01:41 PM] with 'Partial Outage'

Issue has been resolved at [14/06/19 01:43 PM]