BETA

27th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [27/08/18 01:06 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [27/08/18 01:08 PM]