BETA

27th August 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [27/08/18 12:45 PM] with 'Partial Outage'

Issue has been resolved at [27/08/18 12:48 PM]