BETA

16th April 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [16/04/17 02:56 PM] with 'Partial Outage'

Issue has been resolved at [16/04/17 04:24 PM]