BETA

17th July 2016

Incoming SMS Issue observed for Incoming SMS across India

Identified at [17/07/16 08:56 PM] with 'Major Outage'

Issue has been resolved at [17/07/16 08:57 PM]