BETA

27th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [27/08/18 12:39 PM] with 'Major Outage'

Issue has been resolved at [27/08/18 12:50 PM]