BETA

27th August 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [27/08/18 12:32 PM] with 'Partial Outage'

Issue has been resolved at [27/08/18 12:33 PM]