BETA

27th August 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [27/08/18 12:09 PM] with 'Major Outage'

Issue has been resolved at [27/08/18 12:30 PM]