BETA

26th August 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [26/08/18 09:30 PM] with 'Partial Outage'

Issue has been resolved at [26/08/18 09:31 PM]