BETA Singapore cluster       Mumbai cluster

14th June 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [14/06/19 02:52 AM] with 'Partial Outage'

Issue has been resolved at [14/06/19 03:49 AM]