BETA

26th August 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [26/08/18 09:09 AM] with 'Partial Outage'

Issue has been resolved at [26/08/18 09:32 AM]