BETA

26th August 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [26/08/18 04:04 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/08/18 04:17 AM]