BETA

16th April 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [16/04/17 01:46 PM] with 'Partial Outage'

Issue has been resolved at [16/04/17 04:20 PM]