BETA

26th August 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [26/08/18 02:57 AM] with 'Major Outage'

Issue has been resolved at [26/08/18 02:58 AM]